<!DOCTYPE html> <html xmlns="http://www.w3.org/1999/xhtml"> <head> <title>Requisiti sui DBMS</title> <link rel="stylesheet" type="text/css" href="Main.css" /> </head> <body> <h1>Requisiti sui DBMS</h1> <br/> La tabella seguente mostra i DBMS utilizzabili.<br />Il livello di funzionamento previsto e il supporto assicurato dipendono dal DBMS considerato, ma anche dal tipo di utilizzo previsto, ossia: <ul><li>Base di dati principale per il funzionamento dell applicativo.</li> <li>Copia dati, per backup o scambio di dati tra diversi utenti.</li> <li>Sorgente per le importazioni di dati da altri sistemi.</li></ul> <br /><table><tr><th> Database </th><th>Base di dati principale </th><th> Copia dati </th><th> Sorgente importazione </th></tr> <tr><td> SQL Server 2012 or greater for Windows </td><td> Funzionamento certificato </td><td> Funzionamento supportato </td><td> Funzionamento supportato </td></tr> <tr><td> SQL Server 2017 or greater for Linux </td><td> Funzionamento certificato </td><td> Funzionamento supportato </td><td> Funzionamento supportato </td></tr> <tr><td> SQL Server versioni precedenti (*) </td><td> Funzionamento possibile ma non certificato </td><td> Funzionamento supportato </td><td> Funzionamento supportato </td></tr> <tr><td> SQLLite </td><td> </td><td> Funzionamento supportato </td><td> Funzionamento supportato </td></tr> <tr><td> MySQL </td><td> Funzionamento supportato a pagamento </td><td> Funzionamento supportato </td><td> Funzionamento supportato </td></tr> <tr><td> SQL Server Compact </td><td> </td><td> Funzionamento supportato </td><td> Funzionamento supportato </td></tr> <tr><td> SQL Server Azure </td><td> Funzionamento supportato a pagamento </td><td> Funzionamento supportato </td><td> Funzionamento supportato </td></tr> <tr><td> Oracle </td><td> </td><td> </td><td> Funzionamento supportato </td></tr> <tr><td> DB2 </td><td> </td><td> </td><td> Funzionamento supportato a pagamento </td></tr> <tr><td> PostgreSQL </td><td> </td><td> </td><td> Funzionamento supportato </td></tr> <tr><td> Sybase Adaptive Server/SQL Anywhere </td><td> </td><td> Funzionamento supportato a pagamento </td><td> Funzionamento supportato </td></tr> <tr><td> Firebird </td><td> </td><td> </td><td> Funzionamento supportato </td></tr> <tr><td> Informix </td><td> </td><td> </td><td> Funzionamento supportato a pagamento </td></tr> <tr><td> File mdb, accdb </td><td> </td><td> Funzionamento supportato </td><td> Funzionamento supportato </td></tr> <tr><td> File xls </td><td> </td><td> </td><td> Sconsigliato. Funzionamento non supportato </td></tr> <tr><td> File xlsx </td><td> </td><td> </td><td> Sconsigliato. Funzionamento supportato a pagamento </td></tr> <tr><td> File testo (txt, csv, ecc.) </td><td> </td><td> </td><td> Funzionamento supportato a pagamento </td></tr> <tr><td> Any through OLE DB </td><td> </td><td> </td><td> Funzionamento supportato a pagamento </td></tr> <tr><td> Any through ODBC </td><td> </td><td> </td><td> Funzionamento supportato a pagamento </td></tr></table><br /><br />(*) Attualmente unsupported da Microsoft: funzionamento supportato salvo eventuali limitazioni derivanti da tale condizione.<br /> <h2><a href="?Title=Requisiti+DBMS">Scarica pagina come file pdf</a></h2> <br /> <h3>Vedi anche</h3> <a href="?Title=Requisiti+di+sistema">Requisiti di sistema</a><br /> <h3>Tags</h3> install, setup, requisiti, DBMS, database, data base, basi di dati, versione, versioni<br /> </body> </html>